Clique abaixo para nos ajudar
Conectar-se

Esqueci minha senha

Estamos no Facebook
Buscar
 
 

Resultados por:
 


Rechercher Busca avançada

Quem está conectado
13 usuários online :: Nenhum usuário registrado, Nenhum Invisível e 13 Visitantes :: 1 Motor de busca

Nenhum

[ Ver toda a lista ]


O recorde de usuários online foi de 468 em 1/3/2012, 10:43
TRY BEGIN E FLOCK()

17/4/2017, 10:32 por AJC

Pessoal estou tendo alguns problemas de gravação em rede, estou usando
try begin, mas vi algo na …

Comentários: 0

Exportar Dados Campo Memo Tabela DBF

10/4/2017, 10:28 por fcampos

Olá bom dia.

Estou tentando exportar os dados de algumas tabelas em formato dbf pelo foxpro.
O …

Comentários: 2

Função EVL()

8/4/2017, 12:18 por Clebervfp

Bom dia a todos.
Vim compartilhar de uma Função do próprio VFP que me benefício muito.
Função …

Comentários: 0

COMO BLOQUEAR REGISTRO OU TABELA NO VISUAL FOXPRO PARA GRAVAÇÃO EM REDE

3/4/2017, 10:29 por AJC

Pessoal estou tendo um problema que acontece sempre busco na minha tabela de clientes o ultimo …

Comentários: 2

Controlar Scanner Twain

31/3/2017, 17:31 por Kleber R Bento

Estou usando o EZTW32.DLL para criar uma ferramenta que escaneia e gera PDF. Porém com esses …

Comentários: 0

Estatísticas
Temos 7069 usuários registrados
O último usuário registrado atende pelo nome de drudru

Os nossos membros postaram um total de 48 mensagens em 25 assuntos

Algoritmo Para Calcular Equacoes !!

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Em curso Algoritmo Para Calcular Equacoes !!

Mensagem por Brunoads em 26/2/2010, 08:32

Escreva um algoritmo que receba tres valores nas variaveis A,B,C e Calcule as raizes da Equação.
Lembrando: ax²+bx+c=0

Vamos lá!

Código:
inicio

real: a,b,c,d;
escreva("Digite Tres Algarismos");
leia(a,b,c);
se (a=0) [b]e[/b] (b=a) // e → operador logico ex: 1+1= 2 e 1+3= 4 → V
  entao
escreva ("Nao Existe Equaçao");
    senão
se (a=0) e (b‡0)
  então
escreva("Raiz e igual :",-c/b);
 senao
inicio
d <= b*b - 4*a*c;
se (d<0) então
  escreva("Não Tem Raiz Real");
 Senão
Se (d=0)
entao
 escreva("Raiz e Igual:", -b/(2*a));
senao
 escreva("Raizes e Igual :",-b+[b]rad[/b](d)/(2*a),(-b-[b]rad[/b](d))/(2*a)); //Rad → Raiz
fimse;
fimse;
fimse;
fimse;
fimse;
fim.

implementei esse algoritmo e C

http://forum.programacaobrasil.com/c-c-f25/calculando-equacoes-t724.htm
avatar
Brunoads
Começando a Participar
Começando a Participar


Voltar ao Topo Ir em baixo

Em curso Re: Algoritmo Para Calcular Equacoes !!

Mensagem por hugo em 27/2/2010, 14:03

valeu bruno

_________________
"A tristeza é a falta de alegria, mais sem ela eu não poderia entender a alegria do fato de que a felicidade existe!"
Helio Leites - http://www.youtube.com/watch?v=3NUEXX_yOL0
avatar
hugo
Usuário 5 Estrelas
Usuário 5 Estrelas


Voltar ao Topo Ir em baixo

Em curso Re: Algoritmo Para Calcular Equacoes !!

Mensagem por pedro.distur3ed em 1/3/2010, 16:52

nesse algoritimo ta com o mesmo erro do qual vc postou em C
avatar
pedro.distur3ed
Começando a Participar
Começando a Participar


Voltar ao Topo Ir em baixo

Em curso Re: Algoritmo Para Calcular Equacoes !!

Mensagem por pedro.distur3ed em 1/3/2010, 16:53

vou ver se amanha eu faço um alg. desse tipo...ae a gente troca umas infos.
flws
avatar
pedro.distur3ed
Começando a Participar
Começando a Participar


Voltar ao Topo Ir em baixo

Em curso Re: Algoritmo Para Calcular Equacoes !!

Mensagem por hugo em 1/3/2010, 17:04

boa pedro

eh isto ai cara!

pessoas assim como voce fazem o sucesso do forum
e faz bem a todos usuarios!

_________________
"A tristeza é a falta de alegria, mais sem ela eu não poderia entender a alegria do fato de que a felicidade existe!"
Helio Leites - http://www.youtube.com/watch?v=3NUEXX_yOL0
avatar
hugo
Usuário 5 Estrelas
Usuário 5 Estrelas


Voltar ao Topo Ir em baixo

Em curso Re: Algoritmo Para Calcular Equacoes !!

Mensagem por Brunoads em 1/3/2010, 17:28

Entao pedrao ta com aquele erro que tinha te falado brow!
avatar
Brunoads
Começando a Participar
Começando a Participar


Voltar ao Topo Ir em baixo

Em curso Re: Algoritmo Para Calcular Equacoes !!

Mensagem por pedro.distur3ed em 2/3/2010, 09:02

fiz esse algoritimo aki...ve se da pra entender a logica

Código:
inicio

inteiro:a,b,c;
real: d,r1,r2;
escreva("Digite os coeficientes da equação");

leia(a,b,c);
d<-b*b - (4*a*c);
se (d<0) entao
escreva("Nao ha soluçao real");

senao
    se (d>0) entao
    r1<-(-b + rad(d)/(2*a));
    r2<-(-b - rad(d)/(2*a));
    escreva("Raizes:",r1,r2);
   
    senao
      se (d=0) entao
      r1<-r2<-(-b/(2*a));
      escreva("Possui duas raizes iguais a:",r1);
     
      senao
        se (b=0 e c=0) entao
        r1<-r2<-rad(d);
        escreva("Raizes iguais a:",r1);
       
        senao
            se (b=0) entao
            r1<-(-c/a);
              se (r1<0) entao
              escreva("Nao e raiz real");
             
              senao
              escreva("Possui duas raizes reais iguais em modulo a:",r1);
             
              fimse
            fimse
        fimse
      fimse
      fimse
 

fim.
avatar
pedro.distur3ed
Começando a Participar
Começando a Participar


Voltar ao Topo Ir em baixo

Em curso Re: Algoritmo Para Calcular Equacoes !!

Mensagem por hugo em 2/3/2010, 10:54

boa

agora eh so voce testar brunoads e ver se funfa

valeu

hehehe

_________________
"A tristeza é a falta de alegria, mais sem ela eu não poderia entender a alegria do fato de que a felicidade existe!"
Helio Leites - http://www.youtube.com/watch?v=3NUEXX_yOL0
avatar
hugo
Usuário 5 Estrelas
Usuário 5 Estrelas


Voltar ao Topo Ir em baixo

Em curso Re: Algoritmo Para Calcular Equacoes !!

Mensagem por Marcos Guedes em 6/5/2010, 23:18

Funcionou?

_________________
Marcos Guedes - Programador e desenvolvedor Web.


Visite o nosso portal:
http://portal.programacaobrasil.com

Marcos Guedes
Webmaster
Webmaster


Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo


 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum