Clique abaixo para nos ajudar
Conectar-se

Esqueci minha senha

Estamos no Facebook
Buscar
 
 

Resultados por:
 


Rechercher Busca avançada

Quem está conectado
4 usuários online :: Nenhum usuário registrado, Nenhum Invisível e 4 Visitantes

Nenhum

[ Ver toda a lista ]


O recorde de usuários online foi de 468 em 1/3/2012, 10:43
ACESSAR WEBSERVICE COM HTTPS

5/4/2018, 14:48 por AJC

Pessoal recebi este material em C# preciso fazer esta função em vfp9

YourBeanService port = new …

Comentários: 0

REPORT FORM - GERAR 2 RELATORIOS

18/3/2018, 19:02 por AJC

Pessoal, estou tentando gerar dois tipos de relatorio no report form
ou seja
primeira folha - …

Comentários: 2

dll pertocheck

15/12/2016, 12:45 por FERNANDOMATRELLA

Alguem teria ja desenvolvido a comunicação com essa dll estou tento muito trabalho aqui e nenhum …

Comentários: 2

Informações CPF e CNPJ

21/2/2014, 09:46 por mauro victoria

Por favor,
fiquei sabendo da possibilidade de ao digitar o CPF ou CNPJ, o sistema vai no site da …

Comentários: 6

automação do mozilla e chrome

15/1/2017, 12:16 por Handerson Mildroz

Boa tarde a todos!

Sou iniciante no VFP. Preciso de ajuda, pois tenho um código que usa o …

Comentários: 1

Estatísticas
Temos 7095 usuários registrados
O último usuário registrado atende pelo nome de Robson0

Os nossos membros postaram um total de 12257 mensagens em 1554 assuntos

Algoritmo Para Calcular Equacoes !!

Ir em baixo

Em curso Algoritmo Para Calcular Equacoes !!

Mensagem por Brunoads em 26/2/2010, 08:32

Escreva um algoritmo que receba tres valores nas variaveis A,B,C e Calcule as raizes da Equação.
Lembrando: ax²+bx+c=0

Vamos lá!

Código:
inicio

real: a,b,c,d;
escreva("Digite Tres Algarismos");
leia(a,b,c);
se (a=0) [b]e[/b] (b=a) // e → operador logico ex: 1+1= 2 e 1+3= 4 → V
  entao
escreva ("Nao Existe Equaçao");
    senão
se (a=0) e (b‡0)
  então
escreva("Raiz e igual :",-c/b);
 senao
inicio
d <= b*b - 4*a*c;
se (d<0) então
  escreva("Não Tem Raiz Real");
 Senão
Se (d=0)
entao
 escreva("Raiz e Igual:", -b/(2*a));
senao
 escreva("Raizes e Igual :",-b+[b]rad[/b](d)/(2*a),(-b-[b]rad[/b](d))/(2*a)); //Rad → Raiz
fimse;
fimse;
fimse;
fimse;
fimse;
fim.

implementei esse algoritmo e C

http://forum.programacaobrasil.com/c-c-f25/calculando-equacoes-t724.htm
avatar
Brunoads
Começando a Participar
Começando a Participar


Voltar ao Topo Ir em baixo

Em curso Re: Algoritmo Para Calcular Equacoes !!

Mensagem por hugo em 27/2/2010, 14:03

valeu bruno

_________________
"A tristeza é a falta de alegria, mais sem ela eu não poderia entender a alegria do fato de que a felicidade existe!"
Helio Leites - https://www.youtube.com/watch?v=3NUEXX_yOL0
avatar
hugo
Usuário 5 Estrelas
Usuário 5 Estrelas


Voltar ao Topo Ir em baixo

Em curso Re: Algoritmo Para Calcular Equacoes !!

Mensagem por pedro.distur3ed em 1/3/2010, 16:52

nesse algoritimo ta com o mesmo erro do qual vc postou em C
avatar
pedro.distur3ed
Começando a Participar
Começando a Participar


Voltar ao Topo Ir em baixo

Em curso Re: Algoritmo Para Calcular Equacoes !!

Mensagem por pedro.distur3ed em 1/3/2010, 16:53

vou ver se amanha eu faço um alg. desse tipo...ae a gente troca umas infos.
flws
avatar
pedro.distur3ed
Começando a Participar
Começando a Participar


Voltar ao Topo Ir em baixo

Em curso Re: Algoritmo Para Calcular Equacoes !!

Mensagem por hugo em 1/3/2010, 17:04

boa pedro

eh isto ai cara!

pessoas assim como voce fazem o sucesso do forum
e faz bem a todos usuarios!

_________________
"A tristeza é a falta de alegria, mais sem ela eu não poderia entender a alegria do fato de que a felicidade existe!"
Helio Leites - https://www.youtube.com/watch?v=3NUEXX_yOL0
avatar
hugo
Usuário 5 Estrelas
Usuário 5 Estrelas


Voltar ao Topo Ir em baixo

Em curso Re: Algoritmo Para Calcular Equacoes !!

Mensagem por Brunoads em 1/3/2010, 17:28

Entao pedrao ta com aquele erro que tinha te falado brow!
avatar
Brunoads
Começando a Participar
Começando a Participar


Voltar ao Topo Ir em baixo

Em curso Re: Algoritmo Para Calcular Equacoes !!

Mensagem por pedro.distur3ed em 2/3/2010, 09:02

fiz esse algoritimo aki...ve se da pra entender a logica

Código:
inicio

inteiro:a,b,c;
real: d,r1,r2;
escreva("Digite os coeficientes da equação");

leia(a,b,c);
d<-b*b - (4*a*c);
se (d<0) entao
escreva("Nao ha soluçao real");

senao
    se (d>0) entao
    r1<-(-b + rad(d)/(2*a));
    r2<-(-b - rad(d)/(2*a));
    escreva("Raizes:",r1,r2);
   
    senao
      se (d=0) entao
      r1<-r2<-(-b/(2*a));
      escreva("Possui duas raizes iguais a:",r1);
     
      senao
        se (b=0 e c=0) entao
        r1<-r2<-rad(d);
        escreva("Raizes iguais a:",r1);
       
        senao
            se (b=0) entao
            r1<-(-c/a);
              se (r1<0) entao
              escreva("Nao e raiz real");
             
              senao
              escreva("Possui duas raizes reais iguais em modulo a:",r1);
             
              fimse
            fimse
        fimse
      fimse
      fimse
 

fim.
avatar
pedro.distur3ed
Começando a Participar
Começando a Participar


Voltar ao Topo Ir em baixo

Em curso Re: Algoritmo Para Calcular Equacoes !!

Mensagem por hugo em 2/3/2010, 10:54

boa

agora eh so voce testar brunoads e ver se funfa

valeu

hehehe

_________________
"A tristeza é a falta de alegria, mais sem ela eu não poderia entender a alegria do fato de que a felicidade existe!"
Helio Leites - https://www.youtube.com/watch?v=3NUEXX_yOL0
avatar
hugo
Usuário 5 Estrelas
Usuário 5 Estrelas


Voltar ao Topo Ir em baixo

Em curso Re: Algoritmo Para Calcular Equacoes !!

Mensagem por Marcos Guedes em 6/5/2010, 23:18

Funcionou?

_________________
Marcos Guedes - Programador e desenvolvedor Web.


Visite o nosso portal:
http://portal.programacaobrasil.com

Marcos Guedes
Webmaster
Webmaster


Voltar ao Topo Ir em baixo

Em curso Re: Algoritmo Para Calcular Equacoes !!

Mensagem por Conteúdo patrocinado


Conteúdo patrocinado


Voltar ao Topo Ir em baixo

Voltar ao Topo


 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum