Clique abaixo para nos ajudar
Conectar-se

Esqueci minha senha

Estamos no Facebook
Buscar
 
 

Resultados por:
 


Rechercher Busca avançada

Quem está conectado
13 usuários online :: Nenhum usuário registrado, Nenhum Invisível e 13 Visitantes :: 1 Motor de busca

Nenhum

[ Ver toda a lista ]


O recorde de usuários online foi de 468 em 1/3/2012, 10:43
ListBox

23/5/2017, 10:37 por Rosangela Pires

Ola Amigos.

Para se movimentar na grid com as setas colocamos no Metodo AfterChange da grid …

Comentários: 0

TRY BEGIN E FLOCK()

17/4/2017, 10:32 por AJC

Pessoal estou tendo alguns problemas de gravação em rede, estou usando
try begin, mas vi algo na …

Comentários: 0

Exportar Dados Campo Memo Tabela DBF

10/4/2017, 10:28 por fcampos

Olá bom dia.

Estou tentando exportar os dados de algumas tabelas em formato dbf pelo foxpro.
O …

Comentários: 2

Função EVL()

8/4/2017, 12:18 por Clebervfp

Bom dia a todos.
Vim compartilhar de uma Função do próprio VFP que me benefício muito.
Função …

Comentários: 0

COMO BLOQUEAR REGISTRO OU TABELA NO VISUAL FOXPRO PARA GRAVAÇÃO EM REDE

3/4/2017, 10:29 por AJC

Pessoal estou tendo um problema que acontece sempre busco na minha tabela de clientes o ultimo …

Comentários: 2

Estatísticas
Temos 7081 usuários registrados
O último usuário registrado atende pelo nome de DENISON SANTOS DA SILVA

Os nossos membros postaram um total de 49 mensagens em 26 assuntos

EXIBIR CÓDIGO INEXISTENTE

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

EXIBIR CÓDIGO INEXISTENTE

Mensagem por marcos2016 em 7/4/2016, 18:23

TENHO O SEGUINTE CÓDIGO:

algoritmo "AUMENTO DE SALÁRIO DE ACORDO COM O CARGO"
var
salat, nsal, aumento: real
perc, codcarg: inteiro
inicio
escreva("CODIGO DO CARGO DO FUNCIONÁRIO: ")
leia(codcarg)
escreva("ATUAL SALÁRIO DO FUNCIONÁRIO EM R$: ")
leia(salat)
se (codcarg = 1) entao
escreval("CARGO: FAXINEIRO")
aumento <- salat * 50 / 100
escreval("O AUMENTO É DE: ",aumento)
nsal <- aumento + salat
escreva("O NOVO SALÁRIO DESTE CARGO É DE: ",nsal)
senao
se (codcarg = 2) entao
escreval("CARGO: RECEPCIONISTA")
aumento <- salat * 35 / 100
escreval("O AUMENTO É DE: ", aumento)
nsal <- salat + aumento
escreva("O NOVO SALÁRIO DESTE CARGO É DE: ", nsal)
senao
escreva("CODIGO INEXISTENTE!!!!")
fimse
fimse
fimalgoritmo

OBS: QUANDO EU EXECUTO O PROGRAMA E DIGITO O CÓDIGO 3 POR EXEMPLO, O PROGRAMA AINDA PEDE PARA DIGITAR O SALÁRIO DO CARGO, MAS QUERO UMA MANEIRA DE QUANDO EU DIGITAR DO CÓDIGO 3 EM DIANTE O PROGRAMA JÁ MOSTRE A SEGUINTE MENSAGEM: CÓDIGO INEXISTENTE!!!

OBRIGADO.

marcos2016
Participa Pouco
Participa Pouco


Voltar ao Topo Ir em baixo

USO DOCASE

Mensagem por MARCOS em 19/5/2016, 10:02

PRIMEIRO ESPERO QUE TENHA UM FORMULARIO , UMA TABELA COM OS CAMPOS
CODCARGO, ETC...
DO CASE
CASE CODCARGO=1
... CALCULA AQUI
CASE CODCARGO=2
... CALCULAR AQUI
OTHER
MESSAGEBOX("CODIGO INEXISTENTE!!")
ENDCASE

MARCOS
Começando a Participar
Começando a Participar


Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo


 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum